Family & Friends | Mittineague Park | Home | Walk Photos | Wildflowers | Scripting | Sitemap | Blog | Contact |
Mittineague.com Home Mittineague
Welcome to the Mittineague Forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Fatal Error.

 
Posting is closed between 03:00:00 and 06:00:00 (GMT - 4 Hours)
Post new topic   Reply to topic    Mittineague Forum Index -> WordPress
View previous topic :: View next topic  
Author Message
gfindlay
Newcomer
Newcomer



Joined: 07 Oct 2007
Posts: 4

PostPosted: October 07 2007, 11:37    Post subject: Fatal Error. Reply with quote

When I try to run CleanOptions 0.9.4, I get

"Fatal error: Cannot access empty property in /home/gfindlay/public_html/wp-includes/functions.php on line 255"

Running WP 2.3 and a tonne of other plugins.
Back to top
View user's profile Send private message
Mittineague
Site Admin
Site Admin



Joined: 04 Jul 2006
Posts: 68
Location: West Springfield, Massachusetts

PostPosted: October 12 2007, 23:42    Post subject: empty property Reply with quote

AFAIK that line in the functions.php file involves protected options.
I looked again at the Clean Options code, but couldn't see anything obvious (not that there isn't).
When is it bombing out?

  1. you can't activate the plugin
  2. you don't see the panel listed under "Manage"
  3. the "CleanOptions" panel won't load
  4. it errors when you submit the "Find Orphaned Options" button
  5. it errors when you submit the "View Selected Options Information" button
  6. it errors when you "Submit" to remove
  7. Somewhere else?
Back to top
View user's profile Send private message
gfindlay
Newcomer
Newcomer



Joined: 07 Oct 2007
Posts: 4

PostPosted: October 16 2007, 10:41    Post subject: Re: empty property Reply with quote

Mittineague wrote:
When is it bombing out?

4. it errors when you submit the "Find Orphaned Options" button


Everything loads up, up to the point that I click the button, then the error and that's it. No other information, no options to do anything else other than wander elsewhere in the WP admin.
Back to top
View user's profile Send private message
Mittineague
Site Admin
Site Admin



Joined: 04 Jul 2006
Posts: 68
Location: West Springfield, Massachusetts

PostPosted: October 17 2007, 12:45    Post subject: bug Reply with quote

My first thought was that maybe a plugin had put a problem causing option value into the wp_options table. I tried to get the same error by purposely entering various values into the table. A few broke the database syntax, but none gave the "Fatal error: Cannot access empty property .... functions.php on line 255 (or 257 http://www.mittineague.com/blog/2007/04/clean-options-plugin/#comment- 254) message.
Are you using WordPress version 2.+ ??
When you look at view-source, do you see:
Code:
      <div class="wrap">
      <h2>Clean Options</h2>
      <form method="post" action="file name here">

any of the p tags? ie.
Code:
<p>The following Options appear to be orphans.<br />Non-selectable Options .....

any of the inputs? ie.
Code:
<input name='prune_opt[]' type='checkbox' value='rss_ hash number here' />

Thanks for helping me narrow things down Smile
Back to top
View user's profile Send private message
gfindlay
Newcomer
Newcomer



Joined: 07 Oct 2007
Posts: 4

PostPosted: October 18 2007, 19:42    Post subject: Re: Fatal Error. Reply with quote

Here's the code that I'm getting, including the line containing the error:

Code:
<div class="wrap">
<h2>Clean Options</h2>
<form method="post" action="/wp-admin/edit.php?page=cleanoptions.php">
<br />
<b>Fatal error</b>:  Cannot access empty property in <b>/home/o/public_html/wp-content/plugins/clean-options/cleanoptions.p hp</b> on line <b>238</b><br />


And other than the WP 2.3 menu, that's ALL that shows in the source, it stops dead.

This is with the new 0.9.5 version you've posted now.
Back to top
View user's profile Send private message
Mittineague
Site Admin
Site Admin



Joined: 04 Jul 2006
Posts: 68
Location: West Springfield, Massachusetts

PostPosted: October 18 2007, 23:20    Post subject: no name in "option_name" field Reply with quote

When I was testing the other day, I thought that maybe a plugin had added an option without a name. In my tests, this did not break at the displayed list page, but gave a db syntax error breaking at the information review page. In any case, it does seem that an option with no name may be at fault http://www.mittineague.com/blog/2007/04/clean-options-plugin/#comment- 325
This would be consistent with where the script is breaking as indicated by what view-source is showing.
I'll write in code to test for any empty option_name fields and update the plugin repository ASAP
Thanks again.
Back to top
View user's profile Send private message
gfindlay
Newcomer
Newcomer



Joined: 07 Oct 2007
Posts: 4

PostPosted: October 19 2007, 00:25    Post subject: Re: Fatal Error. Reply with quote

You're right. I had a look in phpMyAdmin and there's an entry in the options table with a blank option_name and option_value, but it has an option_id value of 1516, and a blog_id value of 0.

Cool, glad we got that worked out Wink
Back to top
View user's profile Send private message
Display posts from previous:   
Posting is closed between 03:00:00 and 06:00:00 (GMT - 4 Hours)
Post new topic   Reply to topic    Mittineague Forum Index -> WordPress All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum




P o w e r e d   b y   p h p B B   ©   2 0 0 1 ,   2 0 0 5   p h p B B   G r o u p
Family & Friends | Mittineague Park | Home | Walk Photos | Wildflowers | Scripting | Sitemap | Blog | Contact |